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Data Visualization: Bar Graphs and Histograms in Excel, Tableau, and R
Before we get started, make sure that you have Excel, Tableau public, R, and R Studio downloaded and installed.

Bar Graphs and bar charts
William Playfair, who you may remember from our first lecture in this series, is widely recognized as the inventor of the first bar chart (Taylor 2017;
Norman nd). 

Here is another cool historical example of a barchart, created by Florence Nightingale, illustrating the mortality rate of male English civilians with
English soldiers in four different age groups. She wrote in a letter dated August 1857, “Whenever I am infuriated, I revenge myself with a new
diagram” (Gupta 2020). 

Bar vs. Column Chart

The name bar is widely attested and comes from 12th century Old French and Latin barre, barra, meaning bar or barrier (Harper 2001). Bar charts
are commonly also referred to as column charts or graphs, but sometimes these naming conventions refer to either a vertical or horizontal
orientation.
These charts are used often for displaying discrete categorial data, for comparing values across categories, and for illustrating change over time
with time series data.

The X or Y axis generally displays a category and the length or height of the bars are proportional to their representative values. Most often they
are displayed in ascending or descending order!

Excel
Excel has specific naming conventions, calling vertical graphs column charts and horizontal graphs bar charts. Let’s make some in excel now.

Go ahead and open your dataset in excel. (we are using the star wars character dataset from Kaggle.com!!) Feel free to download it there, or you
can use the csv file from Zoom.

First, we will make our bar chart manually, analyzing character genders.

1. create two new columns in your excel spreadsheet: one called gender, the other called count or frequency.
2. list out the possible options in the new gender column (ie male, female, hermaphrodite)
3. under the column labeled count, input the following formula: =COUNTIF(nameoforiginalgendercolumn:endofoggendercolumn, newone) –in

my spreadsheet this results in =COUNTIF(H:H,O2)
4. repeat this by either dragging or manually inputting the same formula so that each different gender is counted
5. highlight these two columns and go to the menu Insert -> Chart -> Column
6. To adjust by ascending or descending order, click home on far left menu.
7. Then select, sort & filter -> custom sort.
8. This will open a new window. Select count or frequency as the column to sort by, and order smallest to largest (or largest to smallest)!

here is an example image of the output in excel!

Alternatively, highlight the original gender column, and then, under the menu bar select Ideas and then count by gender chart.
This prompts a new pivot table and sheet to open in excel, and you can select the required values from there and go to menu Insert -> Chart ->
Column

To adjust colors, axis labels, etc:

Go to Menu -> Chart Design and find Adjust Colors!

To change the orientation to vertical go to Menu -> Insert -> Chart -> Bar

You can click into the chart names and axis names to change or delete them!

Note: I would recommend saving this under a different name as the original Star Wars Character dataset, just for the sake of the other programs
we will be using to make charts during this tutorial!

Tableau Public
Open your original csv file.

Navigate to Sheet 1 (bottom left corner).

1. Click on Gender under the Data menu (left side) and select duplicate.

2. Then click into this new data object, called Gender (copy), and select Create -> Calculated Field

3. In the formula section, delete what is written and change it to Count([Gender])

4. You will then have a new calculated field called calculation 1, and you can change the name to gendercount if you’d like by highlighting it
and typing in the new name.

5. To make a vertical bar graph, move the original gender table to columns, and gender count to rows.

here is an example image of the output in tableau public!

6. To make a horizontal graph, switch these locations. The original gender table will be in rows, and gender count in columns. Note: If you just
switch these data object locations in Tableau, rather than removing them and then re-adding, the orientation of these charts might not
change. Just try again or removing the data from the Columns/Rows locations altogether, then move the data back in!

here is an example image of the output in tableau public with a horizontal orientation!

To change the colors, try dragging the data onto the colors under the Marks menu! Have a play with it, and see what happens. To adjust the color
scheme, click into the colors in the Marks menu.

To adjust the length of any axis, move your cursor to the edge of the axis til it becomes an arrow, click and drag the cursor to change it.

To edit the names, click into the axis and type in your preferred title.

Additional chart settings can be further adjusted from the Marks Menu– Try out selecting different marks and see what happens! Color, Size,
Label, Detail, and Tooltip can all be adjusted there! If you want to publish your graph on tableau public you can save it through there. If you’d
rather just screen shot the image, then it won’t be automatically saved to your tableau public account.

R!!!
We are going to use Barplot and Ggplot to make our charts in R. Open your R studio (integrated development environment) and run the scripts
below.

starwars <- read.csv("/Users/kikuiper/Documents/data_dh/CharStarWars.csv") #input your file path #here
head(starwars) #checks out the data 

 
 

name
<chr>

height
<int>

m…
<chr>

hair_color
<chr>

skin_color
<chr>

eye_color
<chr>

birth_year
<chr>

gender
<chr>

homeworld
<chr>

1 Luke Skywalker 172 77 blond fair blue 19BBY male Tatooine

2 C-3PO 167 75 gold yellow 112BBY Tatooine

3 R2-D2 96 32 white, blue red 33BBY Naboo

4 Darth Vader 202 136 none white yellow 41.9BBY male Tatooine

5 Leia Organa 150 49 brown light brown 19BBY female Alderaan

6 Owen Lars 178 120 brown, grey light blue 52BBY male Tatooine

6 rows | 1-10 of 11 columns

library(tidyverse) #make sure this package is installed using install.packages("tidyverse") before loading the li
brary 

## ── Attaching packages ──────────────────────────────────────────────────────────── tidyverse 1.3.0 ──

## ✓ ggplot2 3.3.2     ✓ purrr   0.3.4
## ✓ tibble  3.0.3     ✓ dplyr   1.0.2
## ✓ tidyr   1.1.2     ✓ stringr 1.4.0
## ✓ readr   1.4.0     ✓ forcats 0.5.0

## ── Conflicts ─────────────────────────────────────────────────────────────── tidyverse_conflicts() ──
## x dplyr::filter() masks stats::filter()
## x dplyr::lag()    masks stats::lag()

#install.packages("plyr")

Now that the data is uploaded, run these commands to prepare it for making the charts.

gendercount <- plyr::count(starwars$gender) 
head(gendercount) #check out the data

 
 

x
<chr>

freq
<int>

1 female 19

2 hermaphrodite 1

3 male 62

4 none 2

5 3

5 rows

#this changes the table names to gender and frequency, and merges the NA and none columns into one called none
gendercount_cleaned <- gendercount %>% set_names(c("gender", "frequency")) %>% mutate(gender=if_else(is.na(gender
), "none", gender)) %>% 
  group_by(gender) %>% summarise( frequency= sum(frequency))

## `summarise()` ungrouping output (override with `.groups` argument)

head(gendercount_cleaned) #check it out!!

gender
<chr>

frequency
<int>

female 19

hermaphrodite 1

male 62

none 5

4 rows

Let’s plot it now!

barplot(height = gendercount_cleaned[["frequency"]], names.arg = gendercount_cleaned[["gender"]]) 

#Make sure your plot window is big enough. 
#you can then click zoom above the plot window to view it in a bigger window

To make changes to the plot:

#add in y axis labels 
barplot(height = gendercount_cleaned[["frequency"]], main = "Character Genders in Star Wars", names.arg = genderc
ount_cleaned[["gender"]], ylab = "Number of Characters") 

#add in x axis labels
barplot(height = gendercount_cleaned[["frequency"]], main = "Character Genders in Star Wars", names.arg = genderc
ount_cleaned[["gender"]], ylab = "Number of Characters", xlab = "Gender") 

#change it to horizontal
barplot(height = gendercount_cleaned[["frequency"]], names.arg = gendercount_cleaned[["gender"]], horiz = T) 

#change the colors!

#add in a uniform color
barplot(height = gendercount_cleaned[["frequency"]], main = "Character Genders in Star Wars", names.arg = genderc
ount_cleaned[["gender"]], ylab = "Number of Characters", xlab = "Gender", col=rgb(0.2,0.4,0.6,0.6)) 

#change the inside shading of the bars
barplot(height = gendercount_cleaned[["frequency"]], main = "Character Genders in Star Wars", names.arg = genderc
ount_cleaned[["gender"]], ylab = "Number of Characters", xlab = "Gender", density=c(5,10,20,30,7), angle=c(0,45,9
0,11,36), col="brown")

#arguments space and width can also change the size of the bars, and the space between each bar

#add in a color palette

#install.packages(RColorBrewer)
library(RColorBrewer)
#create a color palette, the first arguemnt specifics the number of different colors
coul <- brewer.pal(4, "Set2") 
brewertheme <- brewer.pal(4, "BrBG")
?brewer.pal

#use either palette we just created in the col argument function
barplot(height = gendercount_cleaned[["frequency"]], main = "Character Genders in Star Wars", names.arg = genderc
ount_cleaned[["gender"]], ylab = "Number of Characters", xlab = "Gender", col = brewertheme)

Now with ggplot!

ggplot(gendercount_cleaned, aes( x= gender, fill = gender, y = frequency)) + geom_bar(stat="identity")

#add in the title
ggplot(gendercount_cleaned, aes( x= gender, fill = gender, y = frequency)) + geom_bar(stat="identity")+ labs(titl
e="Star Wars Characters by Gender") 

#Make it horizontal
ggplot(gendercount_cleaned, aes( x= gender, fill = gender, y = frequency)) + geom_bar(stat="identity")+ coord_fli
p() 

#add in a color palette from rcolor brewer 
ggplot(gendercount_cleaned, aes( x= gender, fill = gender, y = frequency)) + geom_bar(stat="identity")+ labs(titl
e="Star Wars Characters by Gender") +
  scale_fill_brewer(palette="Accent")

Histograms

 excelhist.png

We will use the same star wars data set to create a histogram of star wars character heights!! Histograms look very similar to vertical bar charts,
but they are actually quite different. Histograms are useful for visualizing the frequency distribution of continuous data and for inspecting
datasets. The data is separated into bins to visualize the distribution. This is easy to do with each of the programs we are utilizing today!

Excel
1. Highlight, copy, and paste star wars character height and move into a new column

2. Remove NAs from the new column.

3. Create a new column called bins and input the values according to whatever increments you would prefer, I’ll be using the values in
increments of 30: 60, 90, 120, 150, 180, 210

4. Highlight the values in these columns, go to data -> data analysis and select Histogram. Make sure that chart output is selected. You will
have to input the values from the cells either with drag and drop or type in the values. (If data analysis is not showing up go to Data ->
Excel Add-ins -> Select Analysis Toolpack)

5. Edit colors and axis labels the same way as with bar charts!

here is an example of the excel histogram!

Tableau Public
manually:

1. Duplicate the height table data object, and change the data type to Number (whole).

2. Make it continuous, then navigate to the menu Create and select Bins.

3. You can change the bin levels (or not); for this, I’ll leave it with the automatic setting.

4. Then duplicate the height object once again, Create Calculated Field Count([Height]), rename it to Count of Heights.

NA NA

NA NA

NA



5. Next, drag the Bins to columns and calculated field to rows!

The easier way…
1. Click on your calculated field count of heights.

2. Click on the drop down menu Show me (right upper corner) and select Histogram.

3. Voila!

4. You can adjust colors, titles, axis labels, etc. the same way as with the bar charts!!

In R Studio:

The code chunks below assumes you have already uploaded the dataset and correct libraries (as shown above for bar graphs).

The first way we’ll make histograms uses the base R graphics system:

#using base r
hist(starwars$height)

#add in the titles
hist(starwars$height, main = "Character Heights in Star Wars",  ylab = "Number of Characters")

#How would we add in the x axis title?

Try out different colors!!

#adjust the colors
hist(starwars$height, main = "Character Heights in Star Wars",  ylab = "", xlab = "", col = brewertheme)

Now, we will make it with ggplot. Ggplot works by layering the data and is very customizable in this way!

#now make it with ggplot!!
ggplot(starwars, aes(x=height)) + geom_histogram()

## `stat_bin()` using `bins = 30`. Pick better value with `binwidth`.

## Warning: Removed 6 rows containing non-finite values (stat_bin).

To adjust things, including the width of the bins

#lets adjust a few things
#change the width of the bins
ggplot(starwars, aes(x=height)) + geom_histogram(binwidth = 5)

## Warning: Removed 6 rows containing non-finite values (stat_bin).

To change colors, feel free to edit the below code or test out other options below!

ggplot(starwars, aes(x=height)) + geom_histogram(color="blue", fill="white")

## `stat_bin()` using `bins = 30`. Pick better value with `binwidth`.

## Warning: Removed 6 rows containing non-finite values (stat_bin).

Looking ahead!
We will learn how to make scatterplots in Excel, Tableau, and R on November 11th, same time same place, and on the 18th of November we will
learn how to make area graphs in Excel, Tableau, and R, also via zoom 4pm est.

Please reach out with any questions, comments, or feedback at katherine.kuiper25@uga.edu!
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